AtomicFU NPM Package Status

#1

The Kotlinx AtomicFU NPM packages from version 0.12.0 onwards are empty, only containing the package descriptor and a readme. I’m relatively new to NPM, so does this reflect a new build process for downloading the AtomicFU package, or has the package been deprecated?

#2

Hi!

I also noticed it and made the mistake of reporting it in a non-dedicated issue on their github, maybe I should report it again in a separate issue.

In the meantime I got over it by copying the .js file from the Maven dependency into the node_modules directory, it works just fine.

I am not sure if the empty package on NPM is intentional and that we must use maven to get the files or not though.