# How to downgrade to Kotlin plugin 1.0.x?

**URL:** <https://discuss.kotlinlang.org/t/how-to-downgrade-to-kotlin-plugin-1-0-x/2349>\
**Category:** Uncategorized\
**Created:** [March 3, 2017, 3:16am UTC](https://discuss.kotlinlang.org/t/how-to-downgrade-to-kotlin-plugin-1-0-x/2349 "2017-03-03T03:16:47Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![nanodeath](https://sea1.discourse-cdn.com/flex019/user_avatar/discuss.kotlinlang.org/nanodeath/32/1803_2.png) [@nanodeath](https://discuss.kotlinlang.org/u/nanodeath)\
**Post date:** [March 3, 2017, 3:16am UTC](https://discuss.kotlinlang.org/t/how-to-downgrade-to-kotlin-plugin-1-0-x/2349/1 "2017-03-03T03:16:48Z")

</div>

I updated the Kotlin plugin in my IntelliJ installation to 1.1, but there are a few critical compiler bugs preventing me from actually using Kotlin 1.1. Naturally I want to downgrade the plugin back to 1.0 because of warnings like this one:

```auto
Kotlin version that is used for building with Gradle (1.0.6) differs from the one bundled into the IDE plugin (1.1.0) 

```

How can I downgrade just the plugin to 1.0.6? Why doesn’t IntelliJ have a `Stable` channel for both 1.0.x and 1.1.x? Not everyone can upgrade immediately to 1.1.x anyway.

---

<div class="post-metadata">

**Author:** ![yole](https://sea1.discourse-cdn.com/flex019/user_avatar/discuss.kotlinlang.org/yole/32/1425_2.png) [@yole](https://discuss.kotlinlang.org/u/yole)\
**Post date:** [March 3, 2017, 8:09am UTC](https://discuss.kotlinlang.org/t/how-to-downgrade-to-kotlin-plugin-1-0-x/2349/2 "2017-03-03T08:09:34Z")

</div>

The warning can be safely ignored; we’ll remove it in one of the nearest 1.1.x updates.

To downgrade the plugin, you need to uninstall it, download the 1.0.6 version corresponding to your IDE version as a file from [plugins.jetbrains.com](http://plugins.jetbrains.com) and install it using the “Install plugin from disk” button. The lack of support for downgrading plugins is a limitation of the IntelliJ Platform at this time.

---

<div class="post-metadata">

**Author:** ![fvasco](https://sea1.discourse-cdn.com/flex019/user_avatar/discuss.kotlinlang.org/fvasco/32/1961_2.png) [@fvasco](https://discuss.kotlinlang.org/u/fvasco)\
**Post date:** [March 3, 2017, 9:31am UTC](https://discuss.kotlinlang.org/t/how-to-downgrade-to-kotlin-plugin-1-0-x/2349/3 "2017-03-03T09:31:18Z")

</div>

A Stable-1.0 channel looks nice for users.

---

<div class="post-metadata">

**Author:** ![yole](https://sea1.discourse-cdn.com/flex019/user_avatar/discuss.kotlinlang.org/yole/32/1425_2.png) [@yole](https://discuss.kotlinlang.org/u/yole)\
**Post date:** [March 3, 2017, 1:45pm UTC](https://discuss.kotlinlang.org/t/how-to-downgrade-to-kotlin-plugin-1-0-x/2349/4 "2017-03-03T13:45:07Z")

</div>

IntelliJ IDEA will suggest the newest version of the plugin available in all active channels, including the default channel. In order to offer the 1.0-Stable channel with the current IntelliJ IDEA plugin update logic implementation, we’d need to stop publishing Kotlin 1.1 into the default channel, and we aren’t going to do that.

---

<div class="post-metadata">

**Author:** ![ilya.gorbunov](https://sea1.discourse-cdn.com/flex019/user_avatar/discuss.kotlinlang.org/ilya.gorbunov/32/1645_2.png) [@ilya.gorbunov](https://discuss.kotlinlang.org/u/ilya.gorbunov)\
**Post date:** [March 3, 2017, 2:26pm UTC](https://discuss.kotlinlang.org/t/how-to-downgrade-to-kotlin-plugin-1-0-x/2349/5 "2017-03-03T14:26:59Z")

</div>

Also note that some future version of IDEA will get Kotlin 1.1 plugin bundled. Then it would be quite hard to downgrade to 1.0.x, because one would have to remove bundled plugin first.

---

<div class="post-metadata">

**Author:** ![nanodeath](https://sea1.discourse-cdn.com/flex019/user_avatar/discuss.kotlinlang.org/nanodeath/32/1803_2.png) [@nanodeath](https://discuss.kotlinlang.org/u/nanodeath)\
**Post date:** [March 3, 2017, 5:13pm UTC](https://discuss.kotlinlang.org/t/how-to-downgrade-to-kotlin-plugin-1-0-x/2349/6 "2017-03-03T17:13:55Z")

</div>

Well, at some point I presume (and hope) you’ll have a LTS release, and then you’ll _have_ to support multiple release channels.

---

<div class="post-metadata">

**Author:** ![yole](https://sea1.discourse-cdn.com/flex019/user_avatar/discuss.kotlinlang.org/yole/32/1425_2.png) [@yole](https://discuss.kotlinlang.org/u/yole)\
**Post date:** [March 3, 2017, 8:00pm UTC](https://discuss.kotlinlang.org/t/how-to-downgrade-to-kotlin-plugin-1-0-x/2349/7 "2017-03-03T20:00:30Z")

</div>

We don’t have any plans to make an LTS release of the plugin. Note that we’ve invested a lot of effort to ensure the compatibility between non-matched versions of the compiler and the plugin, so you’ll be able to keep your project on the compiler version that works for you, while using the latest available version of the plugin.

---

<div class="post-metadata">

**Author:** ![nanodeath](https://sea1.discourse-cdn.com/flex019/user_avatar/discuss.kotlinlang.org/nanodeath/32/1803_2.png) [@nanodeath](https://discuss.kotlinlang.org/u/nanodeath)\
**Post date:** [March 5, 2017, 8:36pm UTC](https://discuss.kotlinlang.org/t/how-to-downgrade-to-kotlin-plugin-1-0-x/2349/8 "2017-03-05T20:36:39Z")

</div>

Alright…I’ve had troubles with plugins even within the 1.0.x version (which, admittedly, I didn’t [document](https://discuss.kotlinlang.org/t/keeping-intellij-kotlin-plugin-and-code-in-sync/2061) terribly well), but I’ll be more diligent about reporting weird PSI bugs.

---

<div class="post-metadata">

**Author:** ![seanf](https://sea1.discourse-cdn.com/flex019/user_avatar/discuss.kotlinlang.org/seanf/32/2277_2.png) [@seanf](https://discuss.kotlinlang.org/u/seanf)\
**Post date:** [March 27, 2017, 3:36am UTC](https://discuss.kotlinlang.org/t/how-to-downgrade-to-kotlin-plugin-1-0-x/2349/9 "2017-03-27T03:36:13Z")

</div>

There do seem to be some problems with compiler/plugin compatibility. This one is becoming a real nuisance: [https://youtrack.jetbrains.com/issue/KT-15778](https://youtrack.jetbrains.com/issue/KT-15778)
