Testing setup in IntelliJ, multiplatform?

#1

I setup a multiplatform project in IntelliJ, and it created a jvmTest module (among others) with a sample unit test. When I click the green arrow in the editor margin, to run a test, it doesn’t work. It seems to be missing the gradle task name, as you can see below. The task name should be jvmTest. Is there a place to set this?

I know I can manually create a run configuration, and that works, but I don’t want to have to do that for every possible test.

Testing started at 15:30 …
15:30:26: Executing task ’ --tests “sample.SampleTestsJVM”’…
Configure project :
Kotlin Multiplatform Projects are an experimental feature.
Task :help
Welcome to Gradle 5.4.
To run a build, run gradle …
To see a list of available tasks, run gradle tasks

#2

I’m able to run tests after going to Preferences > Build, Execution, Deployment > Build Tools > Gradle > Runner, and changing the “Run tests using” drop down from “Gradle Test Runner” to “Platform Test Runner”.

#3

This is a bug, please vote for https://youtrack.jetbrains.com/issue/KT-30814