Hi, so I am using Android Architecture Components and its live data observers and I’m not particulary satisfied with the syntax below. What I am looking for is to at very least replace “dataModel.currentSelectedDisplayTypeLive” with “it”. Or in other terms - how would you beutify the statment below?
dataModel.currentSelectedDisplayTypeLive.observe(this, Observer {onDisplayTypeChanged(dataModel.currentSelectedDisplayTypeLive.value!!) })