I have been using Kotlin for a while now and really love a lot of aspects coupled with its simplicity that it brings. There also however is one item specifically that feels very out of place for me; and in all honesty; syntactically is worse than Java (and how can that be )
In concept I have no issue with the arrayOf, primitive array implementation etc - what I do have an issue with is its syntax. It is ESPECIALLY awkward and long winded in attributes - and while everything is condensed in Kotlin, this one expands already crowded areas. I can offer my suggestion but there are so many clever people involved - just know it feels like a pimple on a Ferrari - completely out of place.
One other thing… this is even more of a personal thing, why did you choose fun as the keyword for function definition? I don’t want to start a troll avalanche towards me, but my personal like is with def; and the fun gets everybody I demo to, to make really boring remarks.