Boolean vs Bool & Integer vs Int

U known in java names is:

int -> java.lang.Integer
boolean -> java.lang.Boolean

In kotlin:

Int (win)
Boolean (lose)

Me interest why Boolean. Maybe better rename to Bool, to save “Short Name Style” for types

I can see no need to change the names, we keep them same as Java.

Hmm.  It seems that in Java different people was created wrappers to primitives

int - > Integer(not Int)
char - Charater(not Char)
booolean - > Boolean

Bool - is more readable than Boolean(when there is Int/Char)