Kapt Gradle: Sources output directory is not specified for custom processor


#1

I have two modules: app and processor.

In an app’s buildfile I have: kapt project(":processor")

When trying to build either of those modules it warns:

w: [kapt] Sources output directory is not specified for processor_main, skipping annotation processing

How can I set that option up?

The same occurs even for jetbrains examples (https://github.com/JetBrains/kotlin-examples)

UPD:

Sorry for distraction. The processor works even with that warning.


#2

Any update on this? It becomes an issue with the new kotlinOptions.allWarningsAsErrors = true option in 1.2.10

w: [kapt] Sources output directory is not specified for xxx_debug, skipping annotation processing
e: warnings found and -Werror specified