Kotlin code not built by run configuration make


#1

I am using Android Studio 2.2.3 on Windows and trying to create a simple module with an executable jar with Kotlin code. I have the Kotlin plugin installed and I do these steps:

  • Say New Module and select a Jar library and give it a name
  • Add a main method to the empty Java class generated with a print statement
  • Right click on the Java file and say to Run the main method
  • Verify that works
  • Delete the build directory
  • Convert the class to Kotlin
  • Configure Kotlin for the module
  • Try running the previous run configuration and it fails with Class Not Found because it didn’t build anything and said everything was up to date

I also tried with a Kotlin run configuration:

  • Right click on the Kotlin class and say run main and it still does not build

I cannot seem to get the Make from the run configuration to actually build the Kotlin files. If I have a mixture of Java and Kotlin files only the Java files get built.

I have tried it both with 1.0.6 and 1.1 Beta. With same results.


#2

FYI, I went ahead and dowloaded IntelliJ and tried similar steps there and did not have a problem there.