Kotlin library has an unsupported format


#1

Upon using the instructions for setting up Kotlin for use in an Android project, I get the following message:

“Kotlin library ‘kotlin-stdlib-0.6.1070.jar’ has an unsupported format. Please update the library of the plugin”

The library is version 0.6.1070 and the plugin is version 0.6.602.

It seems as though your instructions for setting up the gradle build are problematic. You suggest setting the kotlin version to 0.6.+, but it doesn’t appear as though the plugin is tracking with the version of the library that is being released through Maven, and things are getting out of sync. I can still run the build, I just can’t edit in AndroidStudio. If I change the kotlin version in Gradle to 0.6.602, things appear to work fine (though I should note that in both cases, when I actually compile, I get an internal server error, but that is likely independent of these issues).


#2

Added a note here. Thanks!


#3

I had the same problem. I suggest to document the compatible version on plugin page, as I looked there first :)


#4

Sorry, I can not find any latest plugin download link there, Would you please paste it here directly. :p

Thanks.

outersky


#5

Also, I can not find plugin download link at https://github.com/JetBrains/kotlin/tags , only source code there , except M6.1 0.6.602.


#6

M6.1 is the latest released milestone. A new one will be out rather soon.