Kotlin problems with Android studio 0.5.0


#1

Hi,

I upgraded Android studio to 0.5.0 and mixed Java - Kotlin project stopped building. I tried creating a new clean project and even there Kotlin doesn’t work.

Using plugins version 0.7.5 and 0.7.86, I get the following error:

Error:A problem occurred configuring project ‘:app’.
> Could not resolve all dependencies for configuration ‘:app:classpath’.
  > Could not find org.jetbrains.kotlin:kotlin-gradle-plugin:0.7.5.
  Required by:
  MyApplication3:app:unspecified

Nothing changes if I change ext.kotlin_version = ‘0.7.5’ to ‘0.7+’

You can replicate this by creating new project in Android studio, adding a Kotlin file and agreeing with Android studio to add kotlin support. Note that Configure Kotlin in Project only lists kotlin 0.7.5 even though plugin version is different.

thanks.


#2

I also have problem in Android Studio 0.5.0, but different from yours I'm using kotlin-plugin 0.7.100, kotlin-gradle-plugin:0.7+

I got this error:
Gradle project refresh failed:
           INSTRUMENT_TEST

Did you have above gradle error too? If yes, how did you solve it?

EDITED:
I tried also in android studio 0.5.1, but the problem still exist

Thanks


#3

The problem is that last kotlin-android plugin for gradle doesn't support android plugin 0.9+ or higher. We are working on this problem, you can follow this issue - http://youtrack.jetbrains.com/issue/KT-4667. Thank you!


#4

The problem with Android Studio 0.5+ is fixed, you can use kotlin-gradle-plugin 0.7.115.


#5

Hi,

I can confirm that kotlin plugin now works properly with Android Studio 0.5.1.

Thanks.