Make the Kotlin plugin shut up!


#1

Love Kotlin, but the thing that drives me crazy is the Kotlin plugin constantly offering to configure Kotlin for me. I do have it configured! I just do it in a more indirect way that puts all dependency declarations into a separate gradle file so I am not doing it in the way the plugin would, but it is all configured.

I also have run into the fact that I use both Android Studio and Idea and if I have a project in Android Studio that is configured as straight Kotlin (non-Android) it wants to configure it as Kotlin Android and vice-versa in Idea.

I am sick and tired of these notifications. Tell me how to make it shut up!!


Kotlin not configured
#2

I have the same problem. I’ve setup my project using Maven and I’m using Kotlin (Javascript) in several of the sub modules, but IntelliJ want’s to add a Kotlin dependency on the root project (which I don’t).


#3

Kotlin plugin is not too clever at the moment in detecting whether or not your Gradle build depends on Kotlin. Please vote this issue to improve this situation.

Meanwhile, I did not check this myself but judging by the code, introducing two following strings in any form (for example, in comments) into your build.gradle file should help:

  1. apply plugin: 'kotlin' (source)
  2. compile "org.jetbrains.kotlin:kotlin-stdlib:$kotlin_version" (source)

#5

I’m still getting the popup even after copy-pasting these two lines. In case it matters, I’m generating the IntelliJ project using gradlew idea.


#6

You can disable the notification by opening Settings -> Appearance & Behavior -> Notifications and setting the popup setting for “configure Kotlin in Project” to “No popup”. You can also uncheck the “Log” column to disable logging the notification.


#7

I promise I looked for such a setting before starting this thread, but couldn’t find it. I was unfortunately looking under K for Kotlin


#8

I’m not sure exactly what of the following things made it stop, but they did!

The sub-project where the banner wouldn’t go away hadn’t been imported it in my top-level settings.gradle file. In fact, it was configured as a standalone project inside my workspace. So I deleted the settings.gradle file associated with the kotlin sub-project, and then added the import statement for that project in my top-level settings.gradle file.

After that, the IDE stopped bugging me about it. Most of my issues with IntelliJ occur when the Gradle build system is configured differently than the IDE. You might want to go through your build files and make sure all of the dots are connected. Sorry I can’t be more specific; I’m not exactly sure why this worked for me.


#10

@kirill_rakhman explained it really simple and it works, I added a screenshot to it, maybe this can help

In the line where it says “Configure Kotlin in Project” there is a column with “Popup” and you can click in the item there and it will give you more options “No popup” / “Balloon” / “Sticky balloon”:

Try again :wink: