Multiplatform "gradle run --continuous" not reloading js

If i create a mutiplatform project (File → New Project → Full-Stack Web Application) and choose the React Application template, I get a working webapp. I can execute “gradle run” and it will start up the react webapp no problems.

However, i cannot work out how to get continuous / js reload working. I’ve tried “gradle run --continuous” and it doesn’t work.

Am I missing something? Can someone help me out, running the app each time means I have a 1min+ startup each time. is the multi-platform template broken?


Same issue here with Kotlin 1.7.10 and gradle 7.4.2.
Is there any suggestion?

It works for me with jsBrowserDevelopmentRun --continuous, it reloads however I get a blank page that says Cannot GET /

yeah it’s interesting - the mp template appears to have changed since i tried it last about a year ago, i don’t recognize exactly how it’s working now, i’d need to do some digging. it looks like the server side is serving up the content and the webpack bundle.

either way, i couldn’t get it to work and reload. i ended up changing my system to use typescript/react/node.js and it was fairly simple. the reload time is insanely fast in this setup - maybe 0.5s. i like kotlin but the build tools (including the serializationx stuff) is too magical for me.