I would argue that the following case is self explanatory, as easy (if not easier) to understand and it’s the case found most often when using enums:
clearLine(.FromCursorToEnd)
Also, the workarounds proposed are very impractical.
Renaming the enum with an import defeats the whole readability argument and importing everything clutters the context and causes potential for name clashing (think of enums containing color names).
When the compiler clearly knows the type of enum expected, not having to specify it and just using the .ENUM_VALUE syntax seems like a “why wasn’t this a thing in the first place?” kind of thing.