The Android Gradle plugin supports only Kotlin Gradle plugin version 1.2.51 and higher. Project 'this' is using version 1.2.20

#1
apply plugin: 'com.android.application'

apply plugin: ‘kotlin-android’
apply plugin: ‘kotlin-android-extensions’

android {
compileSdkVersion 28
defaultConfig {
applicationId “com.blackbox.ffmpeg.examples”
minSdkVersion 16
targetSdkVersion 28
versionCode 1
versionName “1.0”
testInstrumentationRunner “android.support.test.runner.AndroidJUnitRunner”
}
buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile(‘proguard-android.txt’), ‘proguard-rules.pro’
}
}
}

buildscript {
ext.kotlin_version = ‘1.3.21’
repositories {
google()
jcenter()
}
}
dependencies {
implementation fileTree(include: [’*.jar’], dir: ‘libs’)
testImplementation(‘com.android.support.test.espresso:espresso-core:2.2.2’, {
exclude group: ‘com.android.support’, module: ‘support-annotations’
})

    implementation 'com.android.support:appcompat-v7:28.0.0'
    implementation 'com.android.support:gridlayout-v7:28.0.0'

    testImplementation 'junit:junit:4.12'
    //FFmpeg Library
    implementation 'com.writingminds:FFmpegAndroid:0.3.2'
    implementation 'org.jcodec:jcodec-android:0.1.9'
    //GIF Viewer
    implementation 'pl.droidsonroids.gif:android-gif-drawable:1.2.7'
    implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"

}
repositories {
    mavenCentral()
}

this is my code please help me totally stuck, please help

#2

The kotlin version is specified overall on the parent project. Go look at the other build.gradle file. If not there, the version resolution will be in settings.gradle.

#3

Thanks it can work :blush: