UnsatisfiedLinkError: org.jetbrains.kotlin.relocated.org.fusesource.jansi.internal.CLibrary.init()V


#1

Tried to upgrade to M13 and invoking the compiler now causes this:

Caused by: java.lang.UnsatisfiedLinkError: org.jetbrains.kotlin.relocated.org.fusesource.jansi.internal.CLibrary.init()V at org.jetbrains.kotlin.relocated.org.fusesource.jansi.internal.CLibrary.init(Native Method)      at org.jetbrains.kotlin.relocated.org.fusesource.jansi.internal.CLibrary.<clinit>(CLibrary.java:38)      at org.jetbrains.kotlin.cli.common.messages.PlainTextMessageRenderer.<clinit>(PlainTextMessageRenderer.java:35)      at org.jetbrains.kotlin.cli.common.messages.MessageRenderer.<clinit>(MessageRenderer.java:29)      at org.jetbrains.kotlin.cli.common.CLICompiler.exec(CLICompiler.java:57)      at org.jetbrains.kotlin.cli.common.CLICompiler.doMainNoExit(CLICompiler.java:240)      at org.jetbrains.kotlin.cli.common.CLICompiler.doMain(CLICompiler.java:231)      at org.jetbrains.kotlin.cli.jvm.K2JVMCompiler$Companion.main(K2JVMCompiler.kt:246)

I'm using kotlin-compiler-embeddable.

I filed https://youtrack.jetbrains.com/issue/KT-9196 but thought I’d post here too.