Hi,
I’ve been playing with the idea of using natural language test function names with backticks. e.g.
class MyTest: TestCase() {fun
test empty string
() {
}fun
test single positional parameter
() {
}fun
test multiple positional parameters
() {
}
}
This seems to be a lot more readable than the camel case equivalents such as testMultiplePositionalParameters.
This kinda works. You can run the whole test case using the jUnit Runner - it even demangles the names correctly. However, you can’t run individual tests by right-clicking and you can’t re-run tests from the jUnit Runner. Also, jUnit 4 style tests with Test annotations don’t work at all.
So my question is: should I raise a ticket to support this as a feature? Or should I stop abusing backticks?
Cheers,
Andrew