Build kotlin from sources


I tried to build Kotlin.. but I'am experiencing error during compileStdlib target:

  [mkdir] Created dir: C:UsersSonyIdeaProjectsoskotlindistclassesstdlib   [java] Exception in thread "main" java.lang.NoClassDefFoundError: org/jetbrains/asm4/ClassVisitor   [java]   at com.intellij.core.JavaCoreEnvironment.<init>(   [java]   at org.jetbrains.jet.compiler.JetCoreEnvironment.<init>(   [java]   at org.jetbrains.jet.compiler.CompileEnvironment.<init>(   [java]   at org.jetbrains.jet.cli.KotlinCompiler.exec(   [java]   at org.jetbrains.jet.cli.KotlinCompiler.exec(   [java]   at org.jetbrains.jet.cli.KotlinCompiler.exec(   [java]   at org.jetbrains.jet.cli.KotlinCompiler.doMain(   [java]   at org.jetbrains.jet.cli.KotlinCompiler.main(   [java] Caused by: java.lang.ClassNotFoundException: org.jetbrains.asm4.ClassVisitor   [java]   at$   [java]   at$   [java]   at Method)   [java]   at   [java]   at java.lang.ClassLoader.loadClass(   [java]   at sun.misc.Launcher$AppClassLoader.loadClass(   [java]   at java.lang.ClassLoader.loadClass(   [java]   ... 8 more

How can I fix that?

Message was edited by: Sergey Mashkov


Build on the server is ok.

Did you run “update” target?


Did you run ant -f update_dependencies.xml before it?


Yes, of course.. It failed first because of invalid file name, but I fixed it to "" and then I got success with dependencies.. but still can't get success with build


It looks like something with the classpath so compiler launched with no required libs..


I found org.jetbrains.asm4.ClassVisitor in asm4-all.jar in ideaSDKlib..   I added it to the classpath by hands in build.xml and compilation complete successfully.. but why it does not work from the box?


After invoking update_dependencies you should have asm.jar in ideaSDK/core directory. If you don't, something went wrong. Can you attach log of "ant -f update_dependencies.xml" invocation?


It's strange, because now works, and shouldn't. Maybe you have a little bit outdated version of sources, which points to correct dependency build number, but invalid name of it. Can you check that sources are up-to-date?   


Yes are absolutely right. It was outdated sources version.. after update I got it! Thank you!