Help compiling Kotlin from source


#1

I followed instructions here (https://github.com/JetBrains/kotlin), but I think I'm missing something.  I downloaded EAP IDEA 14, got the Kotlin plugin from the teamcity repository, clone `kotlin` from github, and compiled the kotlin project within the EAP IDEA. Then I selected "Run > Run... IDEA" from the menu.  And within that IDEA, I opened a simple test kotlin project, tried to build it and got:

Error:Internal error: (java.util.ServiceConfigurationError) org.jetbrains.jps.model.serialization.JpsModelSerializerExtension: Provider org.jetbrains.jet.jps.model.KotlinModelSerializerService not found
java.util.ServiceConfigurationError: org.jetbrains.jps.model.serialization.JpsModelSerializerExtension: Provider org.jetbrains.jet.jps.model.KotlinModelSerializerService not found
at java.util.ServiceLoader.fail(ServiceLoader.java:239)
at java.util.ServiceLoader.access$300(ServiceLoader.java:185)
at java.util.ServiceLoader$LazyIterator.nextService(ServiceLoader.java:372)
at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:404)
at java.util.ServiceLoader$1.next(ServiceLoader.java:480)
at com.intellij.util.containers.ContainerUtilRt.copy(ContainerUtilRt.java:155)
at com.intellij.util.containers.ContainerUtilRt.newArrayList(ContainerUtilRt.java:140)

Do I need to set up a class path somewhere? Or it is just the vagaries of the HEAD in git?

Also, is there any hope of building the kotlin plugin like this and then running it in the more stable IDEA 13 that use every day, or is it only going to run in IDEA 14 EAP?

thanks,
Rob


#2

That's looks really strange. Did you do all steps before running debug version of IDEA: "update" ant task, rebuild project, "dist" ant task? Can you try it with current HEAD? It works for me now.

If it doesn’t work for you, please attach content of {kotlin home}/out/artifacts/Kotlin directory.

We support Kotlin for IDEA 13, corresponding version of Kotlin lives in “idea13” branch. We usually merge master into it on each IDEA EAP or Kotlin release   .


#3

I did run those. I just tried to redo everything, same problem.  I pulled from git, ran `ant -f update-dependencies.xml`, then `ant -f build.xml`, then in my IDEA 14, "Run... IDEA", opened kotlin/js project, tried to compile, same error.  I can't attach because the tgz of out/artifacts is 22MB...

Rob


#4

Even with 11MB chunks I get an nginx error here about the size of the request entity. I've uploaded the directory to my web server: http://robnikander.com/files/

Rob


#5

Write, please, what version of IDEA(e.g. 138.1503) and Kotlin plugin(e.g. 0.8.123) do you use.


#6

IntelliJ IDEA (Cassiopeia) 14.0 IU-138.1503.3 Kotlin plugin 0.8.679


#7

Thank you for your attachment.

I looked into it and I see that ‘jps-plugin’ module is was not packed into ‘kotlin-jps-plugin.jar’ at all (while other modules are packed). This jar is generated by IntelliJ IDEA artifacts feature.

Several paranoid checks I can offer:

  1. Go to “Structure -> Artifacts -> KotlinPlugin” and check that there is “jps-plugin compile output” under “<output root>/Kotlin/lib/jps/kotlin-jps-plugin.jar”
  2. Check that there are any class files under “{kotlin home}/out/production/jps-plugin/”
  3. Try to invoke “Build -> Build Artifacts… -> KotlinPlugin -> Rebuild” and run IDEA run configuration after that.

#8

Sweet, that worked.  There were no classes under out/production/jps-plugin. The directory "jps-plugin" did not exist.  I ran Build -> Make module 'jps-plugin' before rebuilding the artifact. I saw the classes show up after making the module.

So it seems like there is something wrong in the dependencies, so that the module wasn’t built when I had nothing and just tried to ‘Run IDEA’.  I don’t know if the problems in the screenshot here are related:

/uploads/kotlinlang/original/1X/3ee8fffd90bc2626b4b6c1742c0510dc42507568.png

thanks,

Rob