From a backwards compatibility standpoint and a Java similarity standpoint, it would be wrong to change the behaviour of the division operator like this.
You can do this with an infix extension function instead.
infix fun Int.fdiv(i: Int): Double = this / i.toDouble();
Then you could do this kind of division like this:
1 fdiv 2
If a new operator would be introduced for this, it could be perhaps be /.
or ./
The precision yielded by this operator (single or double) would have to be inferred somehow, or specified with a prefix or suffix.
It might look out of place and would cause confusion whether or not one should use the ordinary division operator when both operands are not ints.