Eclipse + Kotlin + Junit: @Test annotation errors


#1

Hi,

Whenever I use Junit @Test annotation in Kotlin code(see [1] below), Eclipse (or perhaps Kotlin plug-in for Eclipse) generates a bunch of errors that pop up every ten seconds or so, very annoying:

An internal error occurred during: "Kotlin Analysis".
Wrong annotation argument: 0

An internal error occurred during: "Install semantic highlighting".
Wrong annotation argument: 0

An internal error occurred during: "Compute launch button tooltip".
Wrong annotation argument: 0

An internal error occurred during: "Update occurrence annotations".
Wrong annotation argument: 0

The code[1] builds and runs without errors, the test is run as well and the test report is generated successfully.

Any ideas? Anything I can do to prevent/suspend the above errors? Thanks

My environment:

  • Openjdk 11.0.2 2018-10-16
  • Eclipse Java EE IDE for Web Developers, Version: 2018-09 (4.9.0) Build id: 20180917-1800
  • Kotlin plug-in: 0.8.12
  • Junit 4.12

[1] - test code where the above errors were generated

package test

import org.junit.Assert.assertTrue
import org.junit.Test

class KotlinTests {
	companion object a {
		@JvmStatic
		fun main(args : Array<String>) {
			println("In KotlinTests main: argsSize=${args.size}.")
			println("In KotlinTests main: args=${args.toString()}.")
			println("In KotlinTests main: args0=${args[0]}, args1=${args[1]}.")
		}		
	}
	@Test
	fun runASimpleTest() {
		println("In runASimpleTest")
		assertTrue(true)
    }
}

#2

This particular bug is already fixed in the nightly build of the plugin. You can start using it by installing it from the updatesite: https://teamcity.jetbrains.com/guestAuth/repository/download/Kotlin_EclipsePlugin/.lastSuccessful/.
It will be released as a stable version in the following days. If you find any other bugs feel free to submit them via our youtrack.


#3

Am getting 404 error on that link.

# 404

## Invalid download path: repository/download/Kotlin_EclipsePlugin/latest.lastSuccessful

Tried several links on https://teamcity.jetbrains.com/repository/download/Kotlin_EclipsePlugin/ page, all of them generate “404 Invalid download path” error for me. Thanks


#4

It look like you are trying to use this addresses via web browser. The plugins from update sites are intended to be installed via eclipse Help -> Install new software dialog.


#5

Looks like this update solved the issue for now. Thanks.