Errors following "Getting Started with IntelliJ IDEA page


#1

I have tried following the steps in Getting Started but can never get the resulting project to build or run. I am using IDEA 2016.1.1 and the latest Kotlin plugin.

Currently I create the minimal ‘app.kt’ file shown on the tutorial and try to build and get the following message:

Error:Internal error: (java.lang.NoClassDefFoundError) Could not initialize class org.jetbrains.jps.incremental.BuilderRegistry$Holder
java.lang.NoClassDefFoundError: Could not initialize class org.jetbrains.jps.incremental.BuilderRegistry$Holder
    at org.jetbrains.jps.incremental.BuilderRegistry.getInstance(BuilderRegistry.java:43)
        at org.jetbrains.jps.cmdline.BuildRunner.runBuild(BuildRunner.java:132)
    at org.jetbrains.jps.cmdline.BuildSession.runBuild(BuildSession.java:294)
        at org.jetbrains.jps.cmdline.BuildSession.run(BuildSession.java:125)
    at org.jetbrains.jps.cmdline.BuildMain$MyMessageHandler$1.run(BuildMain.java:232)
        at org.jetbrains.jps.service.impl.SharedThreadPoolImpl$1.run(SharedThreadPoolImpl.java:44)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
        at java.util.concurrent.FutureTask.run(FutureTask.java:262)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at java.lang.Thread.run(Thread.java:745)

I was able to ‘hand-create’ a gradle project that I could build from the command line and then import that into IDEA. So what is the proper incantation to get the Kotlin plugin to work?

Mark


#2

Well, if anyone else has this problem I had to solve it by completely uninstalling IDEA, removing the “Program Files\JetBrains” directory, going to the Users directory and removing all the .idea directories and then re-installing. That solved the problem.


#3

You can also try “File > Invalidate Caches / Restart”.


#4

I was having the same issue, but updating to jdk1.8.0_144.jdk fixed it for me.

57 PM