Errors when opening kotlin project in intellij


#1

I just opened the kotlin intellij project from the files I just cloned but I have a few errors. Anybody having those errors? Any known fix ? When I try to "make project" the first error I have is /home/simon/safe2/referenced/Kotlin-git2/idea/src/org/jetbrains/jet/plugin/debugger/JetPositionManager.java   error: package com.sun.jdi does not exist

I have intellij 11.1 version 114.243


#2

Hi, never mind the source path errors. The guava problem is already fixed.

Make sure to run update_dependencies.xml/update and build.xml/dist before you compile.

If the problem persists, please feel free to ask more questions.


#3

The reason I couldnt make the project has nothing to do with that screenshot. I had to add tools.jar to the idea module dependencies for some reason. A dependency to   com.sun.jdi.AbsentInformationException was not resolved with the project as I got it from git.


#4

So you run update_dependencies.xml, it completed normally, but you still had to add tools.jar?


#5

Yes I ran ant -f update_dependencies.xml many times. Now when I "ctrl-shift-n" or "ctrl-n" in intellij the only place where I can find   com.sun.jdi.AbsentInformationException is in that tools.jar I just added.

What is “ctrl-shift-n” saying about AbsentInformationException on your setup?

Also I tried many jdk. (only linux ones)
and my homemade class finder tells me that no jar contains any class named AbsentInformationException in the idea-full library at ideaSDK/lib.


#6

Thanks for the info.

I was wrong about update_dependencies.xml, the class should be found under the JDK (on Mac it is under classes.jar). So it seems to be a problem with the JDK setup (which is your local settings), maybe it was somehow misconfigured. In any case, It makes sense to add the tools.jar to the JDK, not to the module dependencies.