How to downgrade to Kotlin plugin 1.0.x?


#1

I updated the Kotlin plugin in my IntelliJ installation to 1.1, but there are a few critical compiler bugs preventing me from actually using Kotlin 1.1. Naturally I want to downgrade the plugin back to 1.0 because of warnings like this one:

Kotlin version that is used for building with Gradle (1.0.6) differs from the one bundled into the IDE plugin (1.1.0) 

How can I downgrade just the plugin to 1.0.6? Why doesn’t IntelliJ have a Stable channel for both 1.0.x and 1.1.x? Not everyone can upgrade immediately to 1.1.x anyway.


#2

The warning can be safely ignored; we’ll remove it in one of the nearest 1.1.x updates.

To downgrade the plugin, you need to uninstall it, download the 1.0.6 version corresponding to your IDE version as a file from plugins.jetbrains.com and install it using the “Install plugin from disk” button. The lack of support for downgrading plugins is a limitation of the IntelliJ Platform at this time.


#3

A Stable-1.0 channel looks nice for users.


#4

IntelliJ IDEA will suggest the newest version of the plugin available in all active channels, including the default channel. In order to offer the 1.0-Stable channel with the current IntelliJ IDEA plugin update logic implementation, we’d need to stop publishing Kotlin 1.1 into the default channel, and we aren’t going to do that.


#5

Also note that some future version of IDEA will get Kotlin 1.1 plugin bundled. Then it would be quite hard to downgrade to 1.0.x, because one would have to remove bundled plugin first.


#6

Well, at some point I presume (and hope) you’ll have a LTS release, and then you’ll have to support multiple release channels.


#7

We don’t have any plans to make an LTS release of the plugin. Note that we’ve invested a lot of effort to ensure the compatibility between non-matched versions of the compiler and the plugin, so you’ll be able to keep your project on the compiler version that works for you, while using the latest available version of the plugin.


#8

Alright…I’ve had troubles with plugins even within the 1.0.x version (which, admittedly, I didn’t document terribly well), but I’ll be more diligent about reporting weird PSI bugs.


#9

There do seem to be some problems with compiler/plugin compatibility. This one is becoming a real nuisance: https://youtrack.jetbrains.com/issue/KT-15778