IdeaJ 2018.3 run command does not work with javafx based projects


#1

I am currently working on non-modular Java/Kotlin projects based on Java SDK11 and Openjfx with IdeaJ version 2018.2.6 and appreciate a lot this editor facilites.

I recently tried to upgrade to the latest 2018.3 version but could no longer run or debug a project.
The JVM was unable to load the required javafx modules because the command line settings were incorrect.
This latest version of the editor automatically inserts parameters to load the required javafx modules to run
an application ; the previous versions did not (In that case, it is necessary to add these parameters manually to the project configuration.)

A cursory analysis of the arguments sent to the JVM showed that the javafx.fxml module loading is always missing and the other javafx modules list my not be correct as well.
I tried to force the loading of the missing module(s) by adding some VM options: --module-path="…" and --add-modules=javafx.fxml… but that did not work because the run configuration also uses a --module-path options that supersede my path setting e.g.: -p “…\Java\javafx-sdk-11.0.1\lib\javafx.base.jar; …\Java\javafx-sdk-11.0.1\lib\javafx.graphics.jar”

It appears that the automatic detection of javafx modules required to run a project does not work properly,
at least with non-modular projects.

Incidentally, I have never succeeded to use the JDK9-12 modular system with a
module-info.java file because the Openjfx library is never detected by the editor in that mode, whatever the version.

Until this problem is corrected, I am stuck wtih IdeaJ 2018.2.6


#2

Hello, this seems to be an Intellij IDEA problem, not a Kotlin problem. Please submit an issue here. BTW something similar was recently fixed, but it should also work in 2018.3: https://youtrack.jetbrains.com/issue/IDEA-201715


#3

Hello,

Thank you for your help. I just submitted this issue.

Tonino


#4

For reference, the issue is https://youtrack.jetbrains.com/issue/IDEA-203088