IntelliJ kotlin project screw up


#1

I worked with my kotlin project with IntelliJ IDEA 13.1 on Windows. Then I checked it out on linux machine with 13.1 Community edition. Both machines have 0.7.270 kotlin plugin.

Project compiles and runs OK, but IntelliJ shows: “Unresolved reference: println”, “No set method for array access” on HashMap, etc.

What could be missing or screwed up with IntellJ project with this problem?


#2

Can you try to invalidate caches and restart? From the File menu in IntelliJ.


#3

It seems that your KotlinRuntime library is not attached to the project. Have a look under "Project Structure" If it is there, you can try to delete it an then run "Tools -> Kotlin -> Configure Kotlin in Project"


#4

Invalidating caches and restarting solved the problem. Thank you!

After this I’ve tryed to move/commit/clone the project between windows and linux, all goes flawlessly. Probably the problem was that Kotlin hasn’t been installed on linux Idea (It was automatically installed when I opened the project first time).