Unresolved reference on everything


#1

I created a kotlin project and it was working fine.

But now it’s throwing an error on everyhing(Int, Array, println…)

I tried removing the kotlin module and recofnigure it and it didn’t work.

Strange thing is that when I do “Invalidate Caches/Restart” from the File menu,

the content of the project disappears.

I created my project as
New Project -> Java -> Kotlin/JVM

And now I created a file and the error is thrown right away.


#2

Have you tried closing the project, deleting .idea directory and test.iml file and then using File->New->Project from Existing Sources... (or Import project... on project selection screen if you do not have any project opened)?


#3

Sorry for the late reply.
After doing that, my project lost all kotlin and java related functions.
The module no longer has java and kotlin dependencies.

I tried to make a new module and it created new src folder.
Are there any way to change the existing module settings?


#4

Select the module in ‘Project’ tab and press F4.


#5

Unlike other normal modules this module doesn’t have the proper tabs.

If I add another module to this project, the created module seems normal.

This one seems immutable.

I would like to show the screenshot of it, but I already uninstalled IDEA.

I already have reinstalled it several times but the same error keep occurs, so I decided to move on to eclipse.