Maven error on libraries build (Windows)


#1

I tried to build libraries project on windows 8 according to https://github.com/JetBrains/kotlin/blob/master/libraries/ReadMe.md but got followin maven plugin error

[ERROR] Failed to execute goal org.commonjava.maven.plugins:directory-maven-plugin:0.1:highest-basedir (directories) on project kotlin-project: Cannot find a single highest directory for this project set. First two candidates directories don’t share a common root. -> [Help 1]


full log is here http://pastebin.com/TLnLu03R

how to fix it?


#2

The only case I personally saw this problem, was using a bash shell on ms windows.

Which shell are you using? did you try cmd.exe?


#3

I'm using cmd.exe I've temporarily solved this issue by harcoding path for ${highest-basedir}. but i would prefer to have it solved in general after my "fix" mvn install works as expected, but there is another issue - stdlib generation with mvn test-compile exec:java is failed

[ERROR] Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.2.1:java (default-cli) on project kotlin-stdlib: An exception occured while executing the Java class. org.jetbrains.kotlin.tools.ToolsPackage -> [Help 1]

full log here - http://pastebin.com/hvNUDFhS


#4

Did you run ant build of the project before building libraries?


#5

yes, i've performed following steps

  1. ant -f build.xml in project root
  2. mvn install in librarites
  3. mvn test-compile exec:java in libraries/stdlib

first two was successful, but third has failed


#6

Igor,

This is an issue in Kotlin’s own build process. Investigation is in progress


#7

Igor,

Fix for stdlib generators has been merged into Kotlin’s trunk. Please update.