Migration from 1.3.72 to 1.4.10

I’m using Maven 3.6.3. Trying to migrate project from using Kotlin 1.3.72 to 1.4.10
There is no “1.3.72” text left in my project.
But i’m still having dependency issue:

image

What am I doing wrong?

We just has exactly this discussion in telegram. It is not about 1.4.10, it is about maven dependency resolution. You probably use some library that relies on older stdlib. You have to fix all versions manually in your build. Gradle should do it automatically and take only the newest version.

1 Like

Most likely, you use something like jackson-module-kotlin which depends on 1.3.72 kotlin-stdlib and kotlin-reflect libraries.
I’m trying to get rid of similar issue but with no luck, currently. Old versions gone away from the dependency tree after explicit declaration of 1.4.10 version for kotlin-stdlib, kotlin-stdlib-common and kotlin-reflect libraries, but now I end up with “java.lang.AssertionError: Built-in class kotlin.Any is not found” inside jdbi3-kotlin module, which uses kotlin-reflect library as well during test phase.
UPD: error disappears after switching execution runtime from java 11 to java 8. Version 1.3.72 runs without errors under java 11 (jvmTarget in kotlin-maven-plugin set to 1.8 in both cases).

Try mvn dependency:tree to find out what transitive dependency leads to the old Kotlin version.