Problems with kapt after upgrading to Kotlin plugin 1.1.0


#1

Edit: Solved here

Hi!

I upgraded the Kotlin plugin for IntelliJ to version 1.1.0. I also changed the dependencies and gradle plugin version.
This is my build.gradle. Context: I am creating a plugin for a Minecraft server software/API named ‘Sponge’, it’s like Bukkit if you know that.

The problem I face is this one. It happens when I build the project. When I comment the kapt line out the build succeeds. Here is the annotation processor of the API ‘Sponge’, if that’s needed.

I can workaround this problem by deleting the default ‘additional command line parameters’ of the module(Project structure > Modules > 'select main module' > Additional command line parameters) which includes something of kapt. Here are the dafault parameters. But the parameters come back after a Gradle refresh, so I have to re-delete them again.

The problem doesn’t occur in plugin version 1.0.6.


#2

@davidgreens I saw that you ‘liked’ my post. Do you have the same problem and what’s your setup?


#3

Kotlin 1.1.1-RC has a fix for https://youtrack.jetbrains.com/issue/KT-16184

It seems to be related and I’ve seen this error somewhere in the attempts of fixing my intial issue.
I’ll test the release candidate when I have time.


#4

I have tested it with the mentioned Kotlin 1.1.1-RC. I updated the Kotlin plugin and the gradle build script. After restarting the IDE, cleaning and refreshing gradle the project built successfully!

This issue is solved.

@davidgreens