Strange errors of Idea kotlin plugin


#1

Sorry for bad english, it's not my native language.

When I switched to idea 14.1 and kotlin M12 strange errors highlighted by IDE appeared. Usage of .firstOrNull() or .toArrayList() for example (some other methods gave same error) gave this error: Cannot choose among the following candidates without completing type inference. Maven build still completes successfully. I’ve attached a screenshot where problem is shown.

I tried to google that problem and search it in kotlin bugtracker but didn’t succeeded.

Maybe there is some solution? Or I should work now ignoring this errors and wait for a new version with fix?



err1.png (17.3 KB)

#2

Please check that your project has the correct version of the Kotlin runtime attached, and does not by accident have multiple versions attached to it.


#3

Oh, thank you! I didn't notice that i had two kotlin runtimes in project libraries. One from maven dependencies and one added by kotlin plugin. Removal of KotlinJavaRuntime library, added by plugin helped to solve problem.