Unresolved reference for composite builds

Hi,

I have a KMP project with dependencies to 3 other KMP library projects. I am adding them as dependencies in the build.gradle to sourceSets -> commonMain -> dependencies like this( after adding the path to the settings.gradle with includeBuild):

implementation "net.test:libraryA"
implementation "net.test:libraryB"
implementation "net.test:libraryC"

Until Kotlin 1.4 i didn’t have any problem with this approach. With 1.4 the project is still building but the imports of the dependencies after the first one (libraryB and libraryC in this case) are always showing Unresolved reference errors in the IntelliJ. So basically any local KMP library that i add as a dependency after the first one is showing the same error.

I updated the Kotlin version to 1.4.10 and the Gradle version to 6.3 also I tried invalidate caches/restart with the IDE ( IntelliJ 2020.2.3 Community Edition) but still having the same issues. Does anyone have any idea what the problem might be?

Thanks

1 Like