Version compatibility


#1

Hi,

I am getting this error message from the compiler while trying to run my tests with spek 0.1.122 (latest at the moment) and kotlin 0.7.1217 (also the latest)

Class ‘org/spek/Spek’ was compiled with an incompatible version of Kotlin. Its ABI version is 15, expected ABI version is 16

This means that the format generated by kotlin compiler is not backward compatible?


#2

Until Kotlin 1.0 is released, we don't put much effort into preserving backward compatiblity.


#3

That's the answer I hoped :) Is there any public roadmap for Kotlin btw?


#4

Not really. What would you like to know?


#5

How many many milestones are expected before 1.0?


#6

As many as may be needed. We trade in quality, not in milestones :)


#7

When do you expect a "1.0" and what are the major steps planned till then?


#8

When: I can't give you a good estimate and don't want to give bad ones.

Major steps (language-wise):

  • reflection
  • incremental compilation
  • platform types (no need for annotations to use Java libraries nicely)
  • full support for modules
  • full support of inline functions (non-local returns + optmizations + debug support)
  • support for Java 8’s new features (default methods, streams etc)
  • design revision (fixing many glitches in the syntax, many changes will be breaking, though cosmetic), this will encorporate lots of feedback we are getting from the users inside and outside JetBrains
  • many-many bugfixes, of course

IDE-wise it’s mostly more automated refactorings/intspections and performance optimizations + better debugger support


#9

Major steps (language-wise): - ... - full support for modules ...

What kind of modules do you mean in your statement above ("full support for modules")? Do you mean OSGi modules?


#10

No, I mean compile-time modules, like those you have in the IDE