Module Error?


#1

I have a .kt file, that has little in it. I have tried to remove everything(except for the main “method” if you would call it that in Kotlin) and I still get the same error message. Here is the error message,

Error:Module 'typeFlightMkr' production: java.lang.Exception: LOGGING: Loading modules: [java.se, 
javafx.base, javafx.controls, javafx.fxml, javafx.graphics, javafx.media, javafx.swing, javafx.web, 
jdk.accessibility, jdk.attach, jdk.compiler, jdk.dynalink, jdk.httpserver, jdk.incubator.httpclient, jdk.jartool, 
jdk.javadoc, jdk.jconsole, jdk.jdi, jdk.jfr, jdk.jshell, jdk.jsobject, jdk.management, jdk.management.cmm, 
jdk.management.jfr, jdk.management.resource, jdk.net, jdk.packager, jdk.packager.services, jdk.plugin.dom, 
jdk.scripting.nashorn, jdk.sctp, jdk.security.auth, jdk.security.jgss, jdk.unsupported, jdk.xml.dom, 
oracle.desktop, oracle.net, java.base, java.rmi, java.sql, java.xml, java.logging, java.scripting, 
java.datatransfer, java.compiler, java.xml.crypto, java.prefs, java.sql.rowset, java.naming, java.desktop, 
java.management.rmi, java.management, java.security.sasl, java.instrument, java.security.jgss, 
jdk.internal.jvmstat, jdk.management.agent, jdk.jdwp.agent, jdk.internal.ed, jdk.internal.opt, jdk.internal.le, 
jdk.jdeps, jdk.jlink] (no MessageCollector configured)

I really am not sure what this means, I am no expert at Java, and that is pretty much what Kotlin is. Can someone please help?


#2

See this bug https://youtrack.jetbrains.com/issue/KT-23901


#3

Oh, ok thanks. I thought it was just me with the problem. Is there going to be a fix soon?


#4

In the issue it says it is fixed and the target build is 1.2.41