Unexpected 1.2.70 dependency in 1.3.0-rc-146


#1

Is is normal that 1.3.0-rc-146 depends on 1.2.70? I don’t think so… :thinking:

kotlinCompilerClasspath
\--- org.jetbrains.kotlin:kotlin-compiler-embeddable:1.3.0-rc-146
     +--- org.jetbrains.kotlin:kotlin-stdlib:1.3.0-rc-146 -> 1.2.70
     |    +--- org.jetbrains.kotlin:kotlin-stdlib-common:1.2.70
     |    \--- org.jetbrains:annotations:13.0
     +--- org.jetbrains.kotlin:kotlin-script-runtime:1.3.0-rc-146
     \--- org.jetbrains.kotlin:kotlin-reflect:1.3.0-rc-146 -> 1.2.70
          \--- org.jetbrains.kotlin:kotlin-stdlib:1.2.70 (*)

At least in my project it causes Runtime JAR files in the classpath should have the same version. warnings and compilation failure…


#2

As a workaround, forcing version 1.3.0-rc-146 for all kotlin dependencies solved the compilation error.