Why cant i run a mixed spring boot kotlin and java project just in eclipse?

I have a mixed kotlin / java spring boot project and on eclipse this happens

But if i try to run it on intelliJ, it works just fine. You can’t see in the images but the repositories.kt file has 5 JPA repositories that eclipse doesn’t find and intellij does

I can run locally now but i have to run mvnw spring-boot:run in windows terminal when i run the project the first time. Seems to me that it doesnt run the eclipse kotlin with spring plugin properly.
However each time i edit kotlin code, i have to rerun the command again. Basically seems to me that eclipse finds sources when maven compiles, but cant compile it himself

1 Like

Eclipse Kotlin plugin is not yet fully realized and not fully functional to support your objective, please use intellij or use maven only in your eclipse,

modify your eclipse maven project to auto compile maven only and ignore the Kotlin plugin

1 Like

What a great ideia. Is not like i wanted to use eclipse. Just use the intellij cuz out plug in is trash ^^