"All IDEA Plugin Tests" fail if I run them from IDEA


#1

Hi,

I’ve checked out Kotlin source code from GitHub and opened project in IDEA 12.0.2.
I am able to run plugin using “IDEA” run configuration. It works fine, but when I run “All IDEA Plugin Tests” all tests fail.

There are different types of errors:

  • java.lang.ClassNotFoundException: idea.plugin.psiviewer.controller.application.Configuration
  • java.lang.NoClassDefFoundError: Could not initialize class com.intellij.openapi.vfs.LocalFileSystem$LocalFileSystemHolder
  • ComponentSetup for component com.intellij.openapi.components.impl.ServiceManagerImpl already registered [Plugin: com.intellij]


I tried to install PsiViewer plugin, but it didn’t help.

Has anyone experienced the same problem?

I’ve attached a piece of log with stack traces.



error.txt.zip (2.89 KB)

#2

Hello,

Andrey, I expect you’ve installed PsiViewer plugin into Idea with Kotlin plugin you’ve got with running “IDEA” configuration. Please move “PsiViewer.jar” file from “ideaSDKconfigplugins” into “ideaSDKplugins” directory and the problem should be solved.


#3

It helped. Thank you!