Plugin repository not responding?


#1

I'm getting this, not sure if I'm doing something wrong: /uploads/kotlinlang/original/1X/16191f457aeab82a3ba0f440918617b02d1909c7.png


#2

Doesn't look familiar. I hope it's not caused by Kotlin. :)


#3

Something seems to be wrong, this is probably not normal:

/uploads/kotlinlang/original/2X/6/6e3cda46c2e3ccd493296b8c229cdaf7f4a9a35a.png

I can’t install the plug-in right now.


#4

Looks rather bad, indeed.

We’ll look into it tomorrow.


#5

As it was explained by Leonid Shalupov in this thread, given repositories URLs won't work untill fix for IDEA-82245 is shipped with next EAP. So "Install plugin from disk..." is the best option for getting kotlin for a while.


#6

The new IDEA EAP is out. Please, check if it fixes the problem for you. Thanks


#7

It didn't. I'm now using 116.108 and I'm still seeing this:

/uploads/kotlinlang/original/2X/6/68f92e146391ba5942c8ee5df73c5776d6aba8a7.png

I removed then re-added the plug-site:

http://www.jetbrains.com/kotlin/eap-plugin-repository/updatePlugins.xml

but when I return to the “Manage repositories” window (above), I get the same thing.

So I can’t install the Kotlin plug-in at all.

Any other suggestions?


#8

Suggested repositories URLs are very temporal and it's ok that there're no download statistic, rating and date. In future a stable version of kotlin will be moved to the main repo and this data will be collected properly.

I expect that you have problems with updating because of bad version number of installed plug-in (you can check it in plugins tab in Kotlin details, there should be a valid number like at the screenshot). Please uninstall kotlin plug-in comletely first and install it back from repository URL you have. After that IDEA will be able to check for new versions.

Please give us know did it help and thank you for the helpful feedback.



Kotlin Update.PNG (28.9 KB)

Kotlin Version.PNG (34.4 KB)

#9

FWIW I tried a fresh EAP build (116.108) and tried to use the plugin URL and my experience matched Cedrics - it refused to load. I had to manually download it by hand from the CI build and install from disk to get it to work.


#10

The issue must be fixed as of 1:11 pm today (Moscow time). Please, let us know if it's OK now.