Trouble with EAP


#1


#2

I had this problem, too, and attach my idea.log (zipped as idea.zip (18.9 KB)) because this forum doesn’t allow “.zip” files).

I started today with IntelliJ 2017.1.2 and Kotlin plugin 1.1.2_2. I switched to the EAP 1.2 channel and installed Kotlin plugin 1.1.3-eap-34-IJ2017.2-1. Restarting got me the above error dialog, so I tried updating IntelliJ. That got me IntelliJ 2017.1.3, and the same error on restart.

Looking a bit more closely at those strings, I see that I have a version of the plugin for IJ2017.2 (currently still only in the EAP channel) whereas I’m running 2017.1.x. This seems similar to the version confusion mentioned in https://youtrack.jetbrains.com/issue/KT-17932, and the last comment there sounds like some change was made to plugin info so that people would only get the right version, yet I got the wrong version today.

I upgraded to IJ2017.2 EAP and that works, but the KT-17932 comments make it sound like I should be able to get an EAP version of the Kotlin plugin which is compatible with IJ2017.1.x … I just don’t know how.


Promise coroutines: await doesn't actualy wait